Builder won't build - Printable Version

+- MineColonies (https://forum.minecolonies.com)
+-- Forum: Mod Issues (https://forum.minecolonies.com/forum-11.html)
+--- Forum: Bugs & Compatibility Issues (https://forum.minecolonies.com/forum-20.html)
+--- Thread: Builder won't build (/thread-4399.html)

Builder won't build - BabyBillieGoat - 25.03.2021

I am using 1.16.3 and I have updated the minecolonies mod to the latest version but my builders continue to not build. They won't even build their builders huts. They'll get as far as digging out all of the grass that is needed but then they will just hold a grass block and do nothing. It'll be like they are building but they arent doing anything. I even tried uninstalling mods but it hasn't changed anything Please help. Huh Sad

Edit: I updated to 1.16.5 and I am encountering the same problem. No mods but minecolonies and structurize. She will dig the required holes but will just hold a grass block and try yo place it in different spots and do nothing. I tried taking the dirt away but she asks for it again and wont do anything until she gets it. I restarted her and fired her. I hired someone new and nothing changed.

RE: Builder won't build - teambooster - 28.03.2021

I also encountered that problem. it happened after I built a stonemason and a sawmill and hired a carpenter and a stonemason, I told my builders to build a guard tower and a stone smeltery my builders just removed the grass and then returned to their work station and now they are doing nothing other then just standing near their work station. it seems like they are waiting for the resource even if they have the resource

update: apparently builders have no problem when trying to deconstruct and repair buildings.

update 2: it seems like builders have a limit of building/upgrading buildings and you can increase it by upgrading their hut. I don't know what the exact limit is per builder.

RE: Builder won't build - Pissman2020 - 06.08.2021

I'm having this exact same issue, but I have 3 tier 4 builders and none of them work. They all worked fine, and then I tried to upgrade my combat academy and they all stopped. I have tried firing and rehiring them, hitting them, manually supplying all their requirements, deconstructing and reconstructing the builds they were working on, hiring different colonists and deconstructing and reconstructing the builder's huts. None of these things have worked.

Edit: I found the problem and got them working again! their requests weren't coming to the clipboard because I had a recipe on my crafting huts for what they need, but for some reason the crafters requests for materials my warehouse didn't have weren't going to my clipboard. I had to talk to the builder and check their open requests to see what was holding them up, and once I did that everything started working again.