Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Another GUI not working
I'm running a minecraft 1.11.2 server with minecolonies 7585 (currently the 1.11.2 release candidate on curseforge) on a Linux box. I'd been trying out this mod for several days then I had a power outage that took down the server (not a clean stop of the server).

When I restart all appears well until I connect with a client. None of the GUI's for the minecolonies buildings would open and all the residents appear to have disappeared. Based on another post, I renamed the colonies.dat and colony1.dat files to get them out of the way and expanded the zip archive to recover the most recent backup, then restarted the server. No Joy

Since there were older backup zip files, I went back one more copy and tried that, still not working. There are more of these zip files, but the next older one is nearly 24 hours old and I hesitate.

Thoughts? Suggestions? More info I can provide?
I tried the command /mc colonies list which responds with no items, just "page 1 of 0" and the "prev next" lines. So I tried to place a new supplycamp chest and got the error "You have already placed a supply ship or supply camp!"

Just thought I'd start over using the same world, which seems to be problematic. I copied the entire minecraft 1.11.2 folder and then tried removing various pieces of the ./world/minecolonies/ data, stopping and restarting this new server set up between tries. I first removed the colonies.dat and colony1.dat files then restart, removed the colonies,dat and the backup zip files then restart, and finally deleted the entire ./world/minecolonies folder then restart. At each of these attempts I tried to place a new supplycmp chest and received the message "You have already placed a supply ship or supply camp!"
One thing that did work was to break and replace the minecolonies building objects. Starting with the town hall a break and replace will allow the town halll to be "rebuilt" and the colonists to regenerate. If a building is at it's first build level and you get the building object oriented in the same fashion as before, the builder does recognize that the blocks for that building are "done" and quickly set it as "built". Seems that there is checking to see if any blocks match the building schematic so that block already correct doesn't need to be broken and replaced.
Sounds like a corruption of the minecolonies files to me, due to the power outage. In that case there is a folder inside the world folder called minecolonies, within that there should be a minecolonies.dat and a bunch of zip files date and time stamped, those are backups, so you can replace the minecolonies.dat with one of those, I presume that is in this version but it is rather old, but there are no updates going to 1.11 anymore, so you'd need to update to 1.12 to get further updates.

Forum Jump:

Users browsing this thread: 1 Guest(s)