Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Having trouble creating schematics [SOLVED]
#1
I'm using minecolonies-1.12.2-0.10.109-RELEASE-universal
I'm trying to create some new Hut schematics for a style I'm calling Minimal.
I've been reading here: https://wiki.minecolonies.com/source/tut...ustom-huts
I've managed to build the and scan the shapes I want for the Builder's Hut and the Citizen's Hut, complete with the appropriate chests.
They show up just fine under My Scans, though the files themselves are found in a different location than that specified in the wiki link above.
They're showing up in .minecraft\structurize\scans\new instead of .minecraft\minecolonies\scans\new

Now making them into actual Huts is where I'm running into problems.
I've tried moving Builder1.nbt and Citizen1.nbt into:
.minecraft\structurize\schematics\Minimal
.minecraft\minecolonies\schematics\Minimal
.minecraft\saves\coltest\minecolonies\schematics\Minimal
None of those locations seems to work though.

When I use the building tool in game while I have a Builder's Hut chest and a Citizen's hut chest in my inventory I can only select from the built-in styles for Builder and Citizen. My newly created Minimal style just doesn't show up at all.

What am I doing wrong?

Edit: I figured it out. I had to enable Player-made Schematics in the mod's config by changing allowPlayerSchematics=false to allowPlayerSchematics=true
And .minecraft\structurize\schematics\ is the correct path to store them in. The wiki needs updating to reflect that.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)