Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Chicken herder stuck, sometimes the miner too, since last update.
#1
I've updated to the latest Release yesterday and immediately noticed that some workers get stuck.

They just stand around with their status (above their head) speeding through "NEED ITEM" and "INVENTORY FULL".
These two alternate like 10x per second or so.

There is no request for items, but if I give them the tools they want/need it doesn't reset.
Also recalling them doesn't help.
The inventory is empty or near empty.

If I fire them, close the menu, then rehire them they work again for a day or so.

I noticed that after updating from *.68 (I think, couple of months ago) to *.259 (yesterdays release) this starts to happen.

Repeatedly to the chicken man, which I finally fired and replaced with another worker who has the same problem.
And one of my miners had it once, but after re-hiring him it didn't happen again. Yet...

I didn't see anything in the log about a missing thing or error. Reloading the game (Single player) temporarily solves the issue also.
So it may very well be a buffer kind of thingy that needs to reset for these kinds of jobs. Kind of like a memory leak in an app.

Thoughts?
Reply
#2
I will dig into this
Reply
#3
I read in one of the wiki pages that punching people will reset their logic.
So I went around and punched everyone once or twice while playing.

I'm not sure if that solved anything, but after about 4 hours of playing last night I didn't notice once that a worker was 'stuck' as described above.

Maybe a glitch from the update that resolved itself after a restart or 2. Something with cached configs that now got updated?
Or maybe I was just lucky last night Smile

I'll keep an eye on it.
Reply
#4
Miners still get stuck on "Need item" pretty much every few ingame days.
There is no request for any items.

I have to rehire them to get them to move again.
Reply
#5
The miner "bug" still bugs me, but I figured out what they want. They want fences and planks for the mineshafts.
There is no request for these items though. So it took me a while to figure this out.

At first I thought it was a tools issue. Or maybe monsters in the shafts.
But no, fences and planks made them work again...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)